Running hard disk motor using pic microcontroller - Electronics Forums

Author Topic: Running hard disk motor using pic microcontroller  (Read 8123 times)

rajeshwar1993

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
  • I have a soldering iron and I'm not afraid to use it!
    • View Profile
Running hard disk motor using pic microcontroller
« on: July 27, 2013, 01:30:48 AM »
Hi !
I have tried to run a hard disk motor with a pic 16f84a and a ULN2003 . The motor is rotating but at a very slow rpm. Can anyone please tell me how to increase the rpm using the same circuit? ?
please, its urgent
i am attaching the circuit i'm using and the code below. I'm using mikroc for the project.
please help
Thanks

Electronics Forums

Running hard disk motor using pic microcontroller
« on: July 27, 2013, 01:30:48 AM »

ElectroNick

  • The forum moderator
  • Administrator
  • Full Member
  • *****
  • Posts: 154
  • Karma: +3/-0
  • The soldering iron is ON!
    • View Profile
    • Electronics Blog
Re: Running hard disk motor using pic microcontroller
« Reply #1 on: July 29, 2013, 12:16:18 PM »
It has been some time since I looked at mikroC code, but I don't see the time value for that delay: what exactly is the duration of the delay? Three phase motors like this one have a really serious issue with spinning up to the required speed without missing steps. Sometimes hugely overpowering them works but there is no guarantee.

BTW, +12V on each winding is A LOT of power. They are 3Ω - 6Ω windings, so you may in effect be asking about 4A from your power supply, is it powerful enough?

 

Related Topics

  Subject / Started by Replies Last post
8 Replies
696828 Views
Last post December 09, 2011, 06:13:45 PM
by scoopthepoop
1 Replies
224992 Views
Last post December 17, 2011, 11:37:33 PM
by ElectroNick
14 Replies
20860 Views
Last post June 07, 2013, 11:49:31 AM
by mamette
6 Replies
8263 Views
Last post June 14, 2013, 12:56:18 PM
by antmabee
0 Replies
6480 Views
Last post June 14, 2013, 10:23:16 AM
by ElectroNick